#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)^https?:\/\/(?:www\.)?(.{25}(?:(?<=\w)\w*|\b)).{5,}$"
Local $sString = "https://forum.textpattern.com/viewtopic.php?pid=338199#p338199"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)