using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/(?:www\.)?(.{25}(?:(?<=\w)\w*|\b)).{5,}$";
string substitution = @"$1";
string input = @"https://forum.textpattern.com/viewtopic.php?pid=338199#p338199";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}