use strict;
my $str = 'https://forum.textpattern.com/viewtopic.php?pid=338199#p338199';
my $regex = qr/^https?:\/\/(?:www\.)?(.{25}(?:(?<=\w)\w*|\b)).{5,}$/sp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";