$re = '/(?<=\d)(?=(?:\d\d\d)+\b)/m';
$str = 'Key: 100000,
Value: 120000000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);