$re = '/.*\.git|.*\.classpath|.*target|.*\.settings$/m';
$str = '/var/share/repositories/Icinga/.git
/var/share/test
/var/share/.git
.classpath
target
/help/.settings
/hello
/var/share/repositories/pep-mw-collect/.git/objects/pack/pack-1d6576907088dc6efa7fa64d2092695e07282083.idx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);