# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*\.git|.*\.classpath|.*target|.*\.settings$"
test_str = ("/var/share/repositories/Icinga/.git\n"
"/var/share/test\n"
"/var/share/.git\n"
".classpath\n"
"target\n"
"/help/.settings\n"
"/hello\n"
"/var/share/repositories/pep-mw-collect/.git/objects/pack/pack-1d6576907088dc6efa7fa64d2092695e07282083.idx\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.