#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<phone>\+\d{3,})(?:\/((?&phone)))*$"
Local $sString = "# Should match because all numbers are different" & @CRLF & _
"+123" & @CRLF & _
"+123/+1234" & @CRLF & _
"+123/+1234/+12345" & @CRLF & _
"" & @CRLF & _
"+12345/+1234/+123" & @CRLF & _
"+1234/+12345/+123" & @CRLF & _
"" & @CRLF & _
"+1231/+1232/+1233" & @CRLF & _
"" & @CRLF & _
"# should not match, because exact same number is present twice" & @CRLF & _
"+123/+1234/+123" & @CRLF & _
"+123/+123/+123" & @CRLF & _
"+123/+1234/+1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")