re = /^[^()]*?\([^)]+?\)[^()]*$/m
str = 'Hello abc (canary) (wharf) def ghi
abc (canary) def
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end