Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(\d{3})(-|.) ?(\d{3})[.-](\d{3,4})
/
gm
Input 1
1
New
Frank . 938-345-678 Thomas (345) 654.5654 TC 435.566.333 Rick 245-345.3453