package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(.*?[^a-z\r\n])?((cat|dog)s?)([^a-z\r\n].*?)?$`)
var str = `A likes cat pics
B likes Cats
I adore !!cats!!
H likes cat; he has four of them.
F is catholic
D likes cat!
cat
cats
hello
x likes dogs, he has three of them.
x is dogmatic
dog`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}