use strict;
my $str = 'A likes cat pics
B likes Cats
I adore !!cats!!
H likes cat; he has four of them.
F is catholic
D likes cat!
cat
cats
hello
x likes dogs, he has three of them.
x is dogmatic
dog';
my $regex = qr/^(.*?[^a-z\r\n])?((cat|dog)s?)([^a-z\r\n].*?)?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}