# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=key=\"([^\"]+)\".*)\1|(?=.*key=\"([^\"]+)\".*)\2/***/gm;t' <<< "name=\"prefix1 - key_string suffix1\" displayName=\"prefix1 - key_string suffix2\" key=\"key_string\" name2=\"prefix2 - key_string suffix1\" desc=\"prefix1 - key_string suffix1"