#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\D0[\D\$]"
Local $sString = "(((7+5)*75)+(3*0))+2 = 902" & @CRLF & _
"((7+5)*75)+(3*0))+2 = 902" & @CRLF & _
"(7+5)*75+(3*0)+2 = 902" & @CRLF & _
"(7+5)*75+3*0+2 = 292" & @CRLF & _
"(75-9)*(8-1)-10+0" & @CRLF & _
"0+(75-9)*(8-1)-10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")