re = /\D0[\D\$]/m
str = '(((7+5)*75)+(3*0))+2 = 902
((7+5)*75)+(3*0))+2 = 902
(7+5)*75+(3*0)+2 = 902
(7+5)*75+3*0+2 = 292
(75-9)*(8-1)-10+0
0+(75-9)*(8-1)-10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end