#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{2,5}$)[a-z][a-z0-9]*[0-9][a-z0-9]*$"
Local $sString = "re11e" & @CRLF & _
"a1aaa" & @CRLF & _
"" & @CRLF & _
"aaaa1" & @CRLF & _
"a1000" & @CRLF & _
"1aaaa" & @CRLF & _
"11111" & @CRLF & _
"q99q9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")