using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{2,5}$)[a-z][a-z0-9]*[0-9][a-z0-9]*$";
string input = @"re11e
a1aaa
aaaa1
a1000
1aaaa
11111
q99q9";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}