re = /^(?=.{2,5}$)[a-z][a-z0-9]*[0-9][a-z0-9]*$/m
str = 're11e
a1aaa
aaaa1
a1000
1aaaa
11111
q99q9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end