// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[aA-zZаА-яЯ]\s([0-9])'?").unwrap();
let string = "FT 1 - 0
Добавлено минут 1
HT 0 - 0
Доб авлено минут 5'
add minutes 3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}