const regex = new RegExp('\\b(?!(?:váš|Váš|náš|Náš)\\b)\\w*eš\\b|íš\\b|áš\\b', 'gm')
const str = `Náš počítač je ideální společník na cesty.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}