# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\d)\b/0$1/gm;t' <<< "1-05-2019
2-05-2019
15-05-2019
27-05-2019"