using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d)\b";
string substitution = @"0$1";
string input = @"1-05-2019
2-05-2019
15-05-2019
27-05-2019";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}