use strict;
my $str = '1-05-2019
2-05-2019
15-05-2019
27-05-2019';
my $regex = qr/\b(\d)\b/mp;
my $subst = '0$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";