import re
regex = re.compile(r"\b(\d)\b", flags=re.MULTILINE)
test_str = ("1-05-2019\n"
"2-05-2019\n"
"15-05-2019\n"
"27-05-2019")
subst = "0$1"
result = regex.sub(subst, test_str)
if result:
print(result)