// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d)\b").unwrap();
let string = "1-05-2019
2-05-2019
15-05-2019
27-05-2019";
let substitution = "0$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}