import Foundation
let pattern = #"\b(\d)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1-05-2019
2-05-2019
15-05-2019
27-05-2019
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)