using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(?=\s*(?:Part1|Part2|Part3|Part4))";
string input = @"MatchOnlyMe! Part1 Part2 Part3 Part4
MatchOnlyMe! Part2 Part3 Part4
MatchOnlyMe! Part2 Part3
MatchOnlyMe! Part1 Part3 Part4
MatchOnlyMe! Part3 Part4
MatchOnlyMe! Part4
MatchOnlyMe! Part2
MatchOnlyMe! Part2 Part4
MatchOnlyMe! Part1 Part4
MatchOnlyMe! Part1 Part2 Part4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}