use strict;
my $str = 'MatchOnlyMe! Part1 Part2 Part3 Part4
MatchOnlyMe! Part2 Part3 Part4
MatchOnlyMe! Part2 Part3
MatchOnlyMe! Part1 Part3 Part4
MatchOnlyMe! Part3 Part4
MatchOnlyMe! Part4
MatchOnlyMe! Part2
MatchOnlyMe! Part2 Part4
MatchOnlyMe! Part1 Part4
MatchOnlyMe! Part1 Part2 Part4';
my $regex = qr/^.*?(?=\s*(?:Part1|Part2|Part3|Part4))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}