#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(-?)(\d{1,})((\.\d{0,2})?))$"
Local $sString = "123.09" & @CRLF & _
"123.2345" & @CRLF & _
"123.09" & @CRLF & _
"-12.23" & @CRLF & _
"-100" & @CRLF & _
"100" & @CRLF & _
"" & @CRLF & _
"12356" & @CRLF & _
"123567678" & @CRLF & _
"0" & @CRLF & _
"0.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")