package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^(-?)(\d{1,})((\.\d{0,2})?))$`)
var str = `123.09
123.2345
123.09
-12.23
-100
100
12356
123567678
0
0.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}