re = /^(https?:\/\/)?(www\.)?((?!www)[A-Za-zА-Яа-яЁё0-9\.\-]{2,})\.(.+)$/m
str = 'https://wwtest.ru?12323dsfdfdsfdsf+-*-+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end