use strict;
my $str = 'required : \'This \'asdf\' "asdf" field is required!\', dateISO : \'This is a test...\', digit : \'Example: This is a plausible use of a colon in a jqValidate message.\', number : \'\'Example\': We probably do not use a colon together with single quotes like this, but we can.\', range : \'Any \'text\' here: This is a very unusual \'portion of text\' - isn\'t it?\', whatever : \'Last \'text\' here: \'Even this combination is possible to use!\'\'';
my $regex = qr/:\s*\'((?:(?!:\s*\'(?:.*):\s*\'(?:.*)).)+)\'/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}