use strict;
my $str = 'ABC;ABC;XYZ;PQR;ABC;PQR';
my $regex = qr/(?<=\;|^)(.+?)\;(?=(.+\;)?\1(\;|$))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";