Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
`
^func (\(.*\) )?[a-zA-Z0-9]+?\((.*?)\) [a-zA-Z0-9 ]*?\{
`
gm
Input 1
1
New
func HelloWorld(name string) { fmt.Println(name) } func HelloWorld() { fmt.Println("Hello World") }