#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=[^=\d])\d+(?:\p{Zs}|&\w+;)%"
Local $sString = "some 50%" & @CRLF & _
"and 50 %" & @CRLF & _
"now 50 %" & @CRLF & _
"47 %" & @CRLF & _
"42 %" & @CRLF & _
"width=50%" & @CRLF & _
"this width=42 % shouldn't match" & @CRLF & _
"while a calculation such as result = 27 % may match." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")