re = /\[(.+?)\]\(((?:https?:)?(\/|\\)\3(?:www\.)?.+?\.[a-z]+\3)\)/
str = 'This [is a](https://google.com/) text.
This [is a](https://www.google.com/) text.
This [is a](http://google.com/) text.
This [is a](https:\\\\google.com\\) text.
This [is a](//google.com/) text.
This [is a](https://google./) text.
This [is a](https://.com/) text.
This [is a](https://googlecom/) text.
This [is a](https://google.com) text.'
subst = '<a href="$2">$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result