# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"ALPHA(.*'(BI_\d+)')"
test_str = ("ALPHA;111,'BI_209'\n"
"ALPHA;222,'BI_213'\n"
"ALPHA;AAA,'BI_209'\n"
"ALPHA;FFF,'BI_209'\n"
"ALPHA;123,'BI_220'")
subst = "\\2\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.