#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?:ftp|https?):\/\/|mailto:)(?:\w+(?::\w+)?@)?(?:(?:[a-zA-Z\-][\w+-\.]*)|(?:[\d\.]+))(?:\/\w[\w\.\/%]+)?(?:\?(?:\w+=\w+(?:&\w+=\w+)+))?(?:#\w+)?"
Local $sString = "ftp://sub.domain" & @CRLF & _
"mailto:example@example.com" & @CRLF & _
"http://127.0.0.1/index.htm" & @CRLF & _
"https://user:password@s--ub.do_main.com/path%20/to/whatever.html?key1=value1&key2=value2#fragment"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")