using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:ftp|https?):\/\/|mailto:)(?:\w+(?::\w+)?@)?(?:(?:[a-zA-Z\-][\w+-\.]*)|(?:[\d\.]+))(?:\/\w[\w\.\/%]+)?(?:\?(?:\w+=\w+(?:&\w+=\w+)+))?(?:#\w+)?";
string input = @"ftp://sub.domain
mailto:example@example.com
http://127.0.0.1/index.htm
https://user:password@s--ub.do_main.com/path%20/to/whatever.html?key1=value1&key2=value2#fragment";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}