re = /(?<![.!])(["\']).*?\1/m
str = '"Took 0 seconds"
This is some other content "Took 0 seconds" and some more content
Some more content "Took 1 seconds" and more content ""
!"took 0 seconds"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end