$re = '/^1?\d{10}$/m';
$str = '9803392992
4545454545';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);