$re = '/import[^\']+(?= from \'foo-bar\')/m';
$str = 'import React, { Component } from \'react\'
import { withRouter } from \'react-router-dom\'
import { connect } from \'react-redux\'
import { foo, bar, fooBar } from \'foo-bar\'
import { anotherThing } from \'another-module\'
other stuff here, blah, blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);