use strict;
my $str = 'rabbithole-007
r340j-
8jh
jo9
d366gg-
synthetic-cargo-343207
d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4j-
d4jikkj34jk34j34jk3jk4j
d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4jskdnskjdsjkdnfksfkdjfkdfjkdfdjlkfjdlkfjlkdjflkjdfjdlkfjldkjflkd
rabbit-hole-integration-007';
my $regex = qr/^[a-z][-a-z0-9]{4,28}[a-z0-9]{1}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}