# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-z][-a-z0-9]{4,28}[a-z0-9]{1}$"
test_str = ("rabbithole-007\n"
"r340j-\n"
"8jh\n"
"jo9\n"
"d366gg-\n"
"synthetic-cargo-343207\n"
"d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4j-\n"
"d4jikkj34jk34j34jk3jk4j\n"
"d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4jskdnskjdsjkdnfksfkdjfkdfjkdfdjlkfjdlkfjlkdjflkjdfjdlkfjldkjflkd\n"
"rabbit-hole-integration-007")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.