re = /^[a-z][-a-z0-9]{4,28}[a-z0-9]{1}$/m
str = 'rabbithole-007
r340j-
8jh
jo9
d366gg-
synthetic-cargo-343207
d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4j-
d4jikkj34jk34j34jk3jk4j
d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4jskdnskjdsjkdnfksfkdjfkdfjkdfdjlkfjdlkfjlkdjflkjdfjdlkfjldkjflkd
rabbit-hole-integration-007'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end