// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z][-a-z0-9]{4,28}[a-z0-9]{1}$").unwrap();
let string = "rabbithole-007
r340j-
8jh
jo9
d366gg-
synthetic-cargo-343207
d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4j-
d4jikkj34jk34j34jk3jk4j
d4jikkj34jk34j34jk3jk4j3k4h3jkh4jk3nbdfjk4-4jk3k4jskdnskjdsjkdnfksfkdjfkdfjkdfdjlkfjdlkfjlkdjflkjdfjdlkfjldkjflkd
rabbit-hole-integration-007";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}