using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:email"":\[""|\G(?!\A)"","")\K[^""]+";
string input = @"dias"",""telephone"":"",""email"":[""wsd@gmail.com"",""info@site.ee"",""m@ya.ru""],""address"":{""@type"":""PostalAddress"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}