#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\<title\>).+(?=\<\/title\>)"
Local $sString = "<title>COVEMA</title>" & @CRLF & _
"<title>PALMERO</title>" & @CRLF & _
"<title>PLASTIFERRO</title>" & @CRLF & _
"<title>UOCRA</title>" & @CRLF & _
"<title>REPAS</title>" & @CRLF & _
"<title>BTU</title>" & @CRLF & _
"<title>PANEDILE</title>" & @CRLF & _
"<title>ELEPRINT</title>" & @CRLF & _
"<title>JOSÉ J. CHEDIACK</title>" & @CRLF & _
"<title>NIRO CONSTRUCCIONES</title>" & @CRLF & _
"<title>HELPORT</title>" & @CRLF & _
"<title>BISCAYNE</title>" & @CRLF & _
"<title>COARCO</title>" & @CRLF & _
"<title>ESUCO</title>" & @CRLF & _
"<title>CPC</title>" & @CRLF & _
"<title>TEL 3</title>" & @CRLF & _
"<title>CARTELLONE</title>" & @CRLF & _
"<title>MACRO</title>" & @CRLF & _
"<title>VIAL AGRO</title>" & @CRLF & _
"<title>ISOLUX CORSÁN</title>" & @CRLF & _
"<title>AFCP</title>" & @CRLF & _
"<title>FINNING</title>" & @CRLF & _
"<title>ROGGIO</title>" & @CRLF & _
"<title>ROVELLA CARRANZA</title>" & @CRLF & _
"<title>ACINDAR</title>" & @CRLF & _
"<title>IERIC</title>" & @CRLF & _
"<title>IGARRETA MÁQUINAS</title>" & @CRLF & _
"<title>RIVA</title>" & @CRLF & _
"<title>GRUPO ESTISOL</title>" & @CRLF & _
"<title>IECSA</title>" & @CRLF & _
"<title>ARMAFERRO</title>" & @CRLF & _
"<title>BRICONS</title>" & @CRLF & _
"<title>CNH INDUSTRIAL</title>" & @CRLF & _
"<title>PAOLINI</title>" & @CRLF & _
"<title>SERVIUR</title>" & @CRLF & _
"<title>SANDVIK</title>" & @CRLF & _
"<title>DECAVIAL</title>" & @CRLF & _
"<title>ODEBRECHT</title>" & @CRLF & _
"<title>ENAS</title>" & @CRLF & _
"<title>SITRA</title>" & @CRLF & _
"<title>SUPERCEMENTO</title>" & @CRLF & _
"<title>JCR</title>" & @CRLF & _
"<title>CONSTRUMEX</title>" & @CRLF & _
"<title>BRIALES</title>" & @CRLF & _
"<title>CAPUTO</title>" & @CRLF & _
"<title>LUCIANO</title>" & @CRLF & _
"<title>GALICIA</title>" & @CRLF & _
"<title>VICTOR CONTRERAS</title>" & @CRLF & _
"<title>SIKA ARGENTINA</title>" & @CRLF & _
"<title>CRIBA</title>" & @CRLF & _
"<title>BOETTO Y BUTTIGLIENGO</title>" & @CRLF & _
"<title>MILICIC</title>" & @CRLF & _
"<title>PERIODICO EL CONSTRUCTOR</title>" & @CRLF & _
"<title>PHONERENTAL</title>" & @CRLF & _
"<title>DOS ARROYOS</title>" & @CRLF & _
"<title>MARTINEZ Y DE LA FUENTE</title>" & @CRLF & _
"<title>AUSA</title>" & @CRLF & _
"<title>LUIS LOSI</title>" & @CRLF & _
"<title>AESA</title>" & @CRLF & _
"<title>CONSTRUCTORA SUDAMERICANA</title>" & @CRLF & _
"<title>PLANTEL</title>" & @CRLF & _
"<title>PCR</title>" & @CRLF & _
"<title>BANCO DE LA NACIÓN ARGENTINA</title>" & @CRLF & _
"<title>SUBTERRÁNEOS DE BUENOS AIRES</title>" & @CRLF & _
"<title>HOLA SIM</title>" & @CRLF & _
"<title>JOSÉ LUIS TRIVIÑO</title>" & @CRLF & _
"<title>TECHINT</title>" & @CRLF & _
"<title>EDUARDO COLOMBI</title>" & @CRLF & _
"<title>ALEMARSA</title>" & @CRLF & _
"<title>CENTRO CONSTRUCCIONES</title>" & @CRLF & _
"<title>TECNIPISOS</title>" & @CRLF & _
"<title>XAPOR</title>" & @CRLF & _
"<title>FONTANA NICASTRO</title>" & @CRLF & _
"<title>CONCRET-NOR</title>" & @CRLF & _
"<title>DYCASA</title>" & @CRLF & _
"<title>BURGWARDT</title>" & @CRLF & _
"<title>SULLAIR</title>" & @CRLF & _
"<title>FONDO FIDUCIARIO FEDERAL DE INFRAESTRUCTURA REGIONAL</title>" & @CRLF & _
"<title>FLOWTEX</title>" & @CRLF & _
"<title>PETERSEN THIELE Y CRUZ</title>" & @CRLF & _
"<title>LIHUÉ</title>" & @CRLF & _
"<title>IRAM</title>" & @CRLF & _
"<title>ESTUDIO YMAZ</title>" & @CRLF & _
"<title>VIDOGAR</title>" & @CRLF & _
"<title>BICE</title>" & @CRLF & _
"<title>ROMERO CAMMISA</title>" & @CRLF & _
"<title>BATIMAT</title>" & @CRLF & _
"<title>ALBA CAUCIÓN</title>" & @CRLF & _
"<title>PROBA</title>" & @CRLF & _
"<title>ICF</title>" & @CRLF & _
"<title>TECMA</title>" & @CRLF & _
"<title>ALESTE</title>" & @CRLF & _
"<title>DELEGACIÓN PROVINCIA DE BUENOS AIRES</title>" & @CRLF & _
"<title>HIDRAVIAL</title>" & @CRLF & _
"<title>BANCO CIUDAD</title>" & @CRLF & _
"<title>LAMANNA</title>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")