use strict;
my $str = '<title>COVEMA</title>
<title>PALMERO</title>
<title>PLASTIFERRO</title>
<title>UOCRA</title>
<title>REPAS</title>
<title>BTU</title>
<title>PANEDILE</title>
<title>ELEPRINT</title>
<title>JOSÉ J. CHEDIACK</title>
<title>NIRO CONSTRUCCIONES</title>
<title>HELPORT</title>
<title>BISCAYNE</title>
<title>COARCO</title>
<title>ESUCO</title>
<title>CPC</title>
<title>TEL 3</title>
<title>CARTELLONE</title>
<title>MACRO</title>
<title>VIAL AGRO</title>
<title>ISOLUX CORSÁN</title>
<title>AFCP</title>
<title>FINNING</title>
<title>ROGGIO</title>
<title>ROVELLA CARRANZA</title>
<title>ACINDAR</title>
<title>IERIC</title>
<title>IGARRETA MÁQUINAS</title>
<title>RIVA</title>
<title>GRUPO ESTISOL</title>
<title>IECSA</title>
<title>ARMAFERRO</title>
<title>BRICONS</title>
<title>CNH INDUSTRIAL</title>
<title>PAOLINI</title>
<title>SERVIUR</title>
<title>SANDVIK</title>
<title>DECAVIAL</title>
<title>ODEBRECHT</title>
<title>ENAS</title>
<title>SITRA</title>
<title>SUPERCEMENTO</title>
<title>JCR</title>
<title>CONSTRUMEX</title>
<title>BRIALES</title>
<title>CAPUTO</title>
<title>LUCIANO</title>
<title>GALICIA</title>
<title>VICTOR CONTRERAS</title>
<title>SIKA ARGENTINA</title>
<title>CRIBA</title>
<title>BOETTO Y BUTTIGLIENGO</title>
<title>MILICIC</title>
<title>PERIODICO EL CONSTRUCTOR</title>
<title>PHONERENTAL</title>
<title>DOS ARROYOS</title>
<title>MARTINEZ Y DE LA FUENTE</title>
<title>AUSA</title>
<title>LUIS LOSI</title>
<title>AESA</title>
<title>CONSTRUCTORA SUDAMERICANA</title>
<title>PLANTEL</title>
<title>PCR</title>
<title>BANCO DE LA NACIÓN ARGENTINA</title>
<title>SUBTERRÁNEOS DE BUENOS AIRES</title>
<title>HOLA SIM</title>
<title>JOSÉ LUIS TRIVIÑO</title>
<title>TECHINT</title>
<title>EDUARDO COLOMBI</title>
<title>ALEMARSA</title>
<title>CENTRO CONSTRUCCIONES</title>
<title>TECNIPISOS</title>
<title>XAPOR</title>
<title>FONTANA NICASTRO</title>
<title>CONCRET-NOR</title>
<title>DYCASA</title>
<title>BURGWARDT</title>
<title>SULLAIR</title>
<title>FONDO FIDUCIARIO FEDERAL DE INFRAESTRUCTURA REGIONAL</title>
<title>FLOWTEX</title>
<title>PETERSEN THIELE Y CRUZ</title>
<title>LIHUÉ</title>
<title>IRAM</title>
<title>ESTUDIO YMAZ</title>
<title>VIDOGAR</title>
<title>BICE</title>
<title>ROMERO CAMMISA</title>
<title>BATIMAT</title>
<title>ALBA CAUCIÓN</title>
<title>PROBA</title>
<title>ICF</title>
<title>TECMA</title>
<title>ALESTE</title>
<title>DELEGACIÓN PROVINCIA DE BUENOS AIRES</title>
<title>HIDRAVIAL</title>
<title>BANCO CIUDAD</title>
<title>LAMANNA</title>';
my $regex = qr/(?<=\<title\>).+(?=\<\/title\>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}