$re = '/[a-zA-Z0-9 \'-]*/';
$str = 'liam
liam01
liam-fleming
liam o\'neill
1020asfsd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);