import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+,\\s*'[^',]*).*(',[^,\\n]*)$";
final String string = "119, 'Youth Campus,Janakpur', Janakpur \n"
+ "978, 'Yog Kumar Janta Campus, Balwa-3', Mahottari \n"
+ "806, 'Yerawati Aadarsha Multiple Campus, Lalmatiya Deukhuri, Dang', Dang \n"
+ "613, 'Yasok Campus, Yasok, Panchther', Panchthar \n"
+ "458, 'Yagyodaya Dudhnath Tharu Multiple Campus,Suddhodhan-3,Ramawapur', Rupandehi \n"
+ "1008, 'Yagnyabhumi Multiple Campus, Dharapani', Dhanusha \n"
+ "546, 'Xavier International College, Kamalpokhari,kath', Kathmandu \n"
+ "362, 'Xavier Academy Science College, Lazimpat, Kathmandu', Kathmandu ";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}